Bus Schedules - No Updates for 3 weeks


Their has been no updates to the bus schedules for about three weeks now.

Updates usually occure on Monday Evenings or Tuesday’s after a bank holiday.

Kind Regards

4th week and no update to the schedules!

Hi @Tomfarooqi

My colleagues believe they have identified the cause of the fault. I’m hoping that this will be fixed by the end of tomorrow.

I’ll keep you updated.


Lets hope so!


I hope this means that both problems have been solved - whatever was stopping the weekly update and whatever was causing current WTTs to be overwritten by obsolete ones,

Monday night come and gone. No update. Nothing. Nada.

It is now nearly a month since the last update.

It’s the hope that kills you.

Hi @jamesevans

Still no update, been over a month now.


If there is no update this week, the current WTTs for the new 378, which started a week or two ago, will never see the light of day because the operator for the route changes this coming Saturday. Something similar is probably true (though it will be less obvious) for a number of other routes.

This may not be of earth shattering importance but it is not what is supposed to happen.

So - does the IT team still think it has solved the problem?

hi @mjcarchive @Tomfarooqi

We’re trying to get an update for you.

@theochapple is on the case.


It appears that the issue with the source data system has been resolved. They are now going to try a push to the external store this evening and they’re hopeful this will bring everything up to date.


Thanks, James. Simple nosiness makes me wonder what the nature of he problem(s) has been but I don’t suppose anyone is going to tell me!


From what I understand it was about a config setting making the production storage area the target for test data Very naughty!!


Nothing as of yet James.

They didn’t kick the serve hard enough, James.

Do they think they have sorted out the problem in time for tonight’s update.

If it doesn;t happen that will be five weeks and counting.

5 weeks now gone by @jamesevans

PS @mjcarchive - You triggered the non updates, but complaining about a few minor errors, so now we have nothing at all. next time leave it be!

James - Five weeks now of nothing. Any optimism being fed back to you appears to be misplaced.

Tom - James says it was "about a config setting making the production storage area the target for test data ". That doesn;t sound like anything to do with my pointing put that up to 20% of the links on TfL’s site took you to the wrong pages. That was a rapid deterioration from “a few minor errors” and really had top be addressed.

I don’t like to keep nagging (OK, maybe I do a little bit) but I really do not understand why this is dragging on so long.

@mjcarchive @Tomfarooqi - We’re still investigating why the local copy of the data (which we believe to be correct) is not being transmitted to the public servers. We’ve found this is quite an old method, so we’re doing a little digging into how this works but I am more optimistic on this now.


Why does it have to be a public server any way?

Why cant we access the Ceasar?

So we can access schedules even before they go live.

I agree with @mjcarchive It have taken ages now, over a month.

@jamesevans Can you not just run a update?

I want the 81 schedules that have changed from London United to Metroline, if I email you direct, can you send me the PDFs?