Can't register for an application key

I just made a new account and wanted to try out the api on postman but am unable to register for an application key. Every time I click the link it directs me to the signup page and then directs me back.

Welcome @bobkid

Are you using an ad-blocker? You might need to turn it off to make the registration process work.

Can anyone help please? I have just tried to register for an api key … as per bobkid about a day back. I get exactly the same issue as he did. The screen is momentarily painted with a registration web-form, then reverts to the page that called it … no chance to enter any details. I have tried to register with two PCs, same issue on both, neither has an ad-blocker installed. Is there any other reason for this registration web-form to be simply a flash in the pan? Thanks

After a minor inspiration, I solved this issue by using Firefox browser instead of Google Chrome. But this is the API account sign-up page … I have already signed up. So, where do I find my API key - if signup has given me one? I cannot see it on my user profile. It wasn’t displayed when I originally signed up.
Can anyone help?




OK, it’s Products: List - Transport for London - API and then pick "500 Requests per min " and then “Profile” or just User: Profile - Transport for London - API and bookmark that!