Elizabeth line timetable endpoint not working?

I’m trying to retrieve timetables for the Elizabeth line but calls like these:

https://api.tfl.gov.uk/line/elizabeth/timetable/910GWOLWXR?direction=outbound
https://api.tfl.gov.uk/line/elizabeth/timetable/910GRDNGSTN/to/910GPADTON

All show this error:

“statusErrorMessage”: “The stop you selected has now been removed from the route, and therefore we cannot show you a timetable. The route page will be updated shortly to reflect these changes.”

and no timetable data.

Am I doing something wrong here?

Hi @jdex12 - we don’t have dynamic timetables for Elizabeth line or London Overground.

Please see this post for more info.

Thanks.

Hi @jamesevans - thank you so much for the fast response!

Understood on the Elizabeth line. But we seem to be getting the same error now on the Piccadilly and Circle lines as well. All other tube and DLR lines work fine.

For example, Cockfosters to Uxbridge throws that error:
https://api.tfl.gov.uk/line/piccadilly/timetable/940GZZLUCKS/to/940GZZLUUXB

I also tried individual stations on those lines, getting the same error. For example Finsbury Park works fine for the Victoria Line:
https://api.tfl.gov.uk/Line/victoria/timetable/940GZZLUFPK?direction=outbound

But throws the same error for the Piccadilly line:
https://api.tfl.gov.uk/Line/piccadilly/timetable/940GZZLUFPK?direction=outbound

These worked as recently as a few days ago - has there been any change on this endpoint?

1 Like