Tube Unified API & TrackerNet stale messages

Hi,

I have seen that both the Arrivals Streaming API as well as the TrackerNet API are at certain times providing stale messages, for example (TrackerNet):

(
format:
[data fetched at]
[data extract]
)

 2020-04-26 13:26:46
   <WhenCreated>26 Apr 2020 13:26:23</WhenCreated>
   <T LeadingCarNo="11018" LN="V" TrackCode="TV6610" IsStalled="0" Direction="0" Departed="0" DepartInterval="375" DepartTime="12:26:16" Order="0" DestCode="457" InputDest="" Destination="Walthamstow Central" Location="Between Victoria and Green Park" TimeTo="6:00" SecondsTo="375" TripNo="2" SetNo="012" LCID="67" TrainId="1386031"/>

 2020-04-26 13:43:17
   <WhenCreated>26 Apr 2020 13:26:23</WhenCreated>
   <T LeadingCarNo="11018" LN="V" TrackCode="TV6610" IsStalled="0" Direction="0" Departed="0" DepartInterval="375" DepartTime="12:26:16" Order="0" DestCode="457" InputDest="" Destination="Walthamstow Central" Location="Between Victoria and Green Park" TimeTo="6:00" SecondsTo="375" TripNo="2" SetNo="012" LCID="67" TrainId="1386031"/>
 
 2020-04-26 13:43:46
   <WhenCreated>26 Apr 2020 13:43:37</WhenCreated>

Note how between 13:26:46 and 13:43:17, the WhenCreated (message generation timestamp, presumably) was the same.

Similarly, in the Unified Arrivals streaming feed we can observe the following:

message received at 13:26:20 says:
 train "012" of line Victoria is "Between Victoria and Green Park"
message received at 13:39:47 says:
 train "012" of line Victoria is "Between Victoria and Green Park"

Clearly the messages are also stale here, fresh at 13:26:20 but then stale until 13:40.

This is not the only period during which the message staleness issue appeared, but the first one I found.
By looking at more data, it seems that the issue started last Saturday (2020-04-25), and continues today as well.

Does anyone know why does this happen and is there any updated resource that I’m able to check to indicate that the feed is currently not being updated? For example, some page that says “the real-time Tube predictions are currently delayed” or similar.
I don’t believe I saw this happen in the past, it seems like a new issue, but of course I might be wrong.

Thanks!

1 Like

Hi,

is there any update on this?

With the staleness issue still ongoing, both the tube TrackerNet and Unified Arrivals feeds are not providing meaningful or accurate data, since it can be up to 15 min (or more) out of date.

I have tried the “cache invalidation” solution in StopPoint Arrivals Old Response Via Code (C#) by trying to append a random parameter to the end of the URL, but it doesn’t seem to make any difference, for TrackerNet URLs (like e.g. http://cloud.tfl.gov.uk/TrackerNet/PredictionDetailed/N/HBT)

Today’s example:

URL fetched at 2020-05-01 11:03:30

  <WhenCreated>1 May 2020 11:03:20</WhenCreated>
      <T LeadingCarNo="0" LN="N" TrackCode="TN60343" IsStalled="0" Direction="0" Departed="0" DepartInterval="647" DepartTime="10:03:18" Order="0" DestCode="225" InputDest="HBT3-Y (HBT3//HBT3-Y) [=HBT3/HBT3=Y]" Destination="High Barnet via Bank" Location="At Archway Platform 1" TimeTo="11:00" SecondsTo="647" TripNo="504" SetNo="601" LCID="166" TrainId="11589712"/>

URL fetched at 2020-05-01 11:22:31

  <WhenCreated>1 May 2020 11:03:20</WhenCreated>
      <T LeadingCarNo="0" LN="N" TrackCode="TN60343" IsStalled="0" Direction="0" Departed="0" DepartInterval="647" DepartTime="10:03:18" Order="0" DestCode="225" InputDest="HBT3-Y (HBT3//HBT3-Y) [=HBT3/HBT3=Y]" Destination="High Barnet via Bank" Location="At Archway Platform 1" TimeTo="11:00" SecondsTo="647" TripNo="504" SetNo="601" LCID="166" TrainId="11589712"/>

Unified Arrivals streaming feed log (same vehicle, SetNo 601):

2020-05-01 11:03:37 - 601,Northern 'At Archway Platform 1' generated at 11:03:27 
2020-05-01 11:22:44 - 601,Northern 'At Archway Platform 1' generated at 11:22:33
2020-05-01 11:28:07 - 601,Northern 'Between High Barnet and Totteridge & Whetstone' generated at 11:27:57

Thanks!

I can confirm for the last week or so there has been a latency issue, usually the system updates twice a minute but now sometimes the intervals are 15 - 20 minutes

2 Likes

I’ve had the same issue. There has been some very out of date information in the Arrivals API and Trackernet

1 Like

It seems that the stale messages issue has been fixed - thanks!

Timestamps (today) regarding the TrackerNet feed (presumably the Unified API feed shows a similar pattern):

  • 08:58:08 average message delta is 13 seconds, feed is OK!
  • 09:02:38 average message delta is 3 minutes 41 seconds, feed contains stale messages
  • 12:40:06 average message delta is 27 seconds, feed is OK!

Hi @Shortcut - apologies, my post earlier warning of this didn’t publish for some reason. We had an issue with the feed from Trackernet earlier being stale. That was resolved around lunchtime.

Thanks,
James

1 Like

Hi,

@jamesevans can you please check the feed status?

It seems the last “fresh” TrackerNet prediction messages were updated today at approx. 10:38, and the Unified API - Stream is only sending DLR/Tram predictions.

e.g. today at 2020-05-19 16:34:37

      <WhenCreated>19 May 2020 10:38:55</WhenCreated> 
      <LineName>Victoria Line</LineName>
      <T LeadingCarNo="11039" LN="V" TrackCode="TV6825" IsStalled="0" Direction="0" Departed="0" DepartInterval="0" DepartTime="9:38:19" Order="0" DestCode="88" InputDest="" Destination="Brixton" Location="At Platform" TimeTo="-" SecondsTo="0" TripNo="2" SetNo="006" LCID="78" TrainId="1203901"/>

Thanks!

Hi @Shortcut,

It appears the trackernet team have had a recurrence of the same incident from yesterday.

It’s logged as a high priority incident for it. There appears to be a networking issue that is being investigated.

I’ll let you know once we have any significant updates.
Thanks,
James

2 Likes