Error fetching 246 timetable

Hi there,

I’m getting the following error when calling /Line/246/Timetable/2400A070700A/to/490001036N

{"$type":“Tfl.Api.Presentation.Entities.ApiError, Tfl.Api.Presentation.Entities”,“timestampUtc”:“2019-11-02T16:11:12.9694355Z”,“exceptionType”:“ApiException”,“httpStatusCode”:500,“httpStatus”:“InternalServerError”,“relativeUri”:"/Line/246/Timetable/2400A070700A/to/490001036N",“message”:“No valid route found for 2400A070700A to 490001036N on line: 246”}

According to Line/246/Route, this should give me the inbound timetable for the 246 regular service between Chartwell and Bromley North Station.

Can someone take a look at this? Happy to provide more context if needed.

Thanks

My first thought was that this might somehow relate to the change from summer to winter timetable, Chartwell not being served in the winter, but I see the 246 is still running to Chartwell today. Of course it is not served on Mondays to Saturdays.

Its summer extension is unusual these days and any unusual features should perhaps be the first port of call for investigation.

Have you tried it with a stop further north that is always served?

Very strange - /Line/246/Timetable/2400A070700A (i.e. without an endpoint) works just fine and returns a timetable route ending in 490001036N but, as you say, adding the endpoint returns a code 500

Thanks both.

Yes, it appears to fail with the same error when setting any destination stop along the 246 route from Chartwell. As you mention, it appears to work when not setting a destination.

I’m attempting to fetch timetables for route sections, so setting the section destination in the timetable URL to be explicit. For now I can probably get away with dropping the destination parameter if this is just an API issue rather than a data one.