Journey planner down?


#1

Anybody else finding that the journey planner https://tfl.gov.uk/plan-a-journey/ is currently delivering only bus journeys?

Or, with bus unticked and everything else selected, it’s giving no results at all?


Bug in Journey planner not offering Tube
#2

Strange, its working on my mobile but not on desktop


#3

Same problems here on my W10 PC, but it is working normally on my Android tablet.


#4

Yes, this is still the case for me. The API’s all seem fine, I think it’s something that is being filtered out on the front-end (the journeys are coming back, but they are just not being shown). Interesting that this has been broken for at least 5 days with no action. (Like the map views in the bus section which hasn’t worked for years).


#5

Are you using firefox? This seems to be caused by a firefox addon, though I’ve not yet identified which one. However, if I restart firefox with addons disabled (an option in the help menu), I get trains in the result.

So, I suspect unlikely to be a TFL bug.


#6

Useful info. It wasn’t working for me in Chrome, but quickly fired up incognito to get all my plugins turned off and it worked. I only have an ad blocker and privacy badger installed, so might be one of those.


#7

I tried in a firefox 65.0.1 without any extensions (in a virtual machine), I got the same result until I reduced my “Content Blocking” (in Preferences/“Privacy & Security”) from custom (with some quite strict choices) to standard,

In my standard browser (Firefox 60 with several privacy&security-enhancing extensions I can’t even see the options for selecting travel time without allowing javascript from google.com. Also no results at all are shown without javascript from there. Almost all the reasons google can have to host scripts on there rather than e.g. gstatic.com comes down to their ability to track us, i.e. it’s bad.


#8

Yes, I found the same but have not yet had time to report back.

The problem is unrelated to any of my firefox addons. It occurs with these totally standard and wholly desirable settings:

Adding tfl,gov.uk to the exceptions list does not change anything. The problem is almost certainly the result of google’s despicable and wholly unnecessary spyware.

I did manage to establish that the command sent to the server was identical with and without tracking protection. In the web console, the “missing” train journeys can be seen within the server’s response. So the server is behaving properly – its the client that is somehow improperly suppressing display of the information when tracking is disabled.

The display problem does not affect bus journeys so there must be some difference in the display of the train journeys which is causing this bug.

TFL should urgently investigate this problem and find a way to ensure that full results are displayed, not just with the basic protection but even when tracking protection is set to “strict”.